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Before taking this course you should be familiar with the skills taught in the Skills for the 
Electronic Workplace course called "Excel Level 1". These skills include: 
 
•  Formatting cells 
•  Filling down a formula 
•  Workbooks 
•  Linking 
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•  Importing non-Excel data 
•  Charts 
•  Printing 
 
In this course you will be using Excel to look after the course registrations for the Skills for the 
Electronic Workplace training program. In addition to course registration, the workbook is used 
for keeping track of the accounting and supplies used for the courses.  
 
This hands-on session was created using Excel 2002 (part of the Office XP suite). Most of the 
instructions will work no matter what version you are using, but there may be some that are 
different in older versions of Excel. In this document you will notice instructions written as 
(Format=>Cells). This means choose “Cells” from the “Format” menu. 
 

Excel Templates and Data Validation 
Excel templates and data validation are two completely different topics. We are going to use data 
validation in an Excel template. This probably doesn't mean a lot to you at this point, but it soon 
will. 
 
1. Start Excel and open a worksheet called "registration" from the X-drive.  
 
This worksheet is an outline, or a template that we will use to register staff and faculty for each 
course. The top part contains information about the course. The rest of the sheet will be used for 
registration information. A total of 30 people can register for a course. After 30 people have 
registered, a waiting list is formed. Take a look at this worksheet to get an idea of the type of 
information we will be keeping track of.  
 
We would like to make the data input a little easier. In cell G11, you will notice a heading called 
"Admin/Faculty". For each person registering for this course, we would like to know if they are 
from Admin, Arts, AHS, Engineering, ES, Math, or Science. Rather than type the information in 
for each person, we can select it from a list. This also ensures things are entered consistently.  
 
2. Select cell G12. From the "Data" menu choose "Validation" (Data=>Validation).  
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3. Select List from the "Allow" drop down box. In the "Source" box, enter the following: 
 

Admin,AHS,Arts,Engineering,ES,Math,Science 
 
Click on the "OK" button. You will notice the down arrow adjacent to the "Admin/Faculty" 
cell. Clicking on the down arrow will display the list of possible choices for the cell. Fill this 
cell down to cell G41. 
 

4. Click on cell B6. From the "Data" menu, choose "Validation" (Data=>Validation). Click on 
the "Input Message" tab. The following window will appear: 
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5. In the "Input message" box, type in "Enter the name of the course". Click the "OK" button. 
 
6. From the File menu, click "Save As" and in the "Save as type" box pick "Template". Notice 

the name of the template is "registration".  

 
Also notice that the extension on this file is "xlt", and it is being saved into the Microsoft 
templates folder. Click on the "Save" button. Close the worksheet. 
 

7. To check that it worked, choose “General Templates” in the “New Workbook” pane. A new 
window will appear, providing you with the choice of selecting the registration.xlt template. 
Double-click on the registration.xlt icon. You are now entering information into a new 
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spreadsheet called registration1.xls. Close this worksheet for now, and we will use the 
template later. 

 

Using the Database Features of Excel 

Sorting Data 
We are going to open a workbook that is similar to the one used to keep track of the registrations 
for the SEW courses that were offered in January and February 2002. 
 
1. From the X-drive, open the workbook called janfeb02registrations.  
 
2. Notice that there is a worksheet for three courses ("Win2000", "Excel Level 1", "PowerPoint 

Level 1",) that were taught and contain the names of the people registered for the courses.  
 
3. Select the "Win2000" course (if it is not already selected). Click on cell C12 (or on any cell 

in the data range). 
 
4. From the "Data" menu, choose "Sort" (Data=>Sort). The following window will open: 
 

 
5. Notice that you are sorting by "Last Name". Make sure you are sorting in ascending order. 

Click on the "OK" button. 
 
6. Make sure your data is sorted correctly. If you want to undo the sort, simply click "Undo 

Sort" from the "Edit" menu.  
 
7. Try sorting the data by faculty, and within faculty, sort by "Last Name". 
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Filtering Data 
Filtering data means that you are selecting rows from the spreadsheet that meet a specific 
criteria. For example, we may want to list all the people from "Science" that attended the 
"PowerPoint Level 1" course.  
 
8. Choose the registration sheet for the "PowerPoint Level 1" course. Click on cell A12 (or on 

any cell within the registration list).  
 
9. From the "Data" menu, choose "Filter" and then "AutoFilter", as shown below: 

10. You should notice that the column titles now have down arrows following them. 

 
11. Click on the down arrow for the "Faculty" column, and then choose "Science". You should 

now be looking at the people from the Faculty of Science that attended the "PowerPoint 
Level 1" course. 

 
12. Notice that the down arrow for the "Faculty" column is now in blue. This tells you that you 

are looking at a subset of the data. Click on this blue down arrow, and then click on "All". 
You should now have all the data back, and the down arrow is now black. 

 
13. You can also use filters on more than one column at a time. Suppose we want to list all the 

staff (i.e. not faculty) from the faculty of Science taking this course. From the "down arrow" 
in the "Faculty" cell choose "Science".  

 
14. From the "down arrow" in the "Position" cell, choose "Staff". Notice that you should now see 

two blue "down arrows"…one for "Faculty", and one for "Position". You are now looking at 
the data you wanted…all the staff in the Faculty of Science taking this course. Let's get back 
to the original data by choosing "All" in both the "Faculty" and "Position" cells. 

 
15. You can use filters on numerical data as well. This is a really useful feature. Click on the 

"Accounting" worksheet. We would like to know which of the supplies (folders, diskettes 
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etc) cost more than 50 cents each. Click on cell A6, or on any cell in the data range that we 
are searching (A4:B7).  

 
16. Turn on filters (Data=>Filter=>AutoFilter). Click on the "down arrow" in the "Cost per 

Item" cell, and choose "Custom". The following window will appear: 

 
17. Change this window so that it looks like the following, and then click the "OK" button. 
 

 
18. You should now be looking at the only those supplies that cost greater than 50 cents.  
 
19. Select all the data again by clicking on the "down arrow" in the "Cost per Item" cell again 

and choosing "All". 
 
20. Click the "down arrow" on the "Cost per Item" cell. You will notice an item listed called 

"(Top 10…)". Choose this item, the following window appears: 
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21. Change the 10 to a 3 and click the "OK" button. The three most expensive items will be 
listed.  

 
22. Select all the data again by clicking on the "down arrow" in the "Cost per Item" cell again 

and choosing "All". 
 
Filtering is something you will probably use quite often in Excel. 

Subtotals 
After the courses are over, we need to get some statistics from the registration data. For example, 
for the "Win2000" course, we would like to know how many people attended from each faculty, 
and how many were from Admin areas.  
 
23. Select the "Win2000" sheet. Click on cell C21 (or on any cells in the A12:H41 range). 
 
24. The first step for subtotals is to sort the data. We want to sort the data by "Faculty". Do that 

now (Data=>Sort). 
 
25.  From the "Data" menu, choose "Subtotals". A window similar to the following will appear, 

but with different entries in each of the boxes. We want to make your window look like the 
following: 
 

 
 
Whenever the "Faculty" changes we want to count the number of people. Click on the first down 
arrow for "At each change in" and choose "Faculty". 

 
26. Click on the second down arrow for "Use function" and choose Count (it may already be set 

to "Count"). 
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27. Now from the "Add subtotal to" box, choose "Faculty". Deselect anything else that is 
checked. What we are asking Excel to do here is count the number of entries for "Faculty" 
(We could have asked Excel to count any of the other fields). 

 
28. Now click on the "OK" button. Your screen will change and look something like the 

following: 
 

 
 
You will notice the new area on the left side of the window that is circled in the above window.  
We will experiment with this now. 
 
29. Click the number "2" in the above left corner (circled above).  We should now have the 

information we need, as shown below: 
 

Admin Count 17
Engineering Count 1
Science Count 5
Grand Count 23

 
30. To remove the subtotals, choose "Subtotals" from the "Data" menu, and then click the 

"Remove all" button. 
 

Counting Non-Blank Cells 
 
1. Select the "Excel Level 1" course (if it is not already selected). In cell A43, type in "Total 

Registered". 
2. In cell B43, we want to count the number of non-blank cells from cell B12 to B41. We can 

use the COUNTA function as follows: 
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=COUNTA(B12:B41) 
 

3. Repeat steps (1) and (2) for the "Win2000" and the "PowerPoint Level 1" course. 
 

Absolute References 
Understanding Absolute References is not easy. You only have to worry about the concept when 
you are doing a "Fill" in any direction.  
 
1. Select  the "Inventory" sheet. Select cell C5. We want to put in a formula in this cell to 

calculate how many folders were used in the January and February courses. As you can 
probably recall, we can get this information from cell B43 in each of the sheets "Win2000", 
"Excel Level 1" and "PowerPoint". Enter in the following formula: 

 
='Win2000'!B43+'Excel Level 1'!B43+'Powerpoint Level 1'!B43 
 
You don't have to type all this formula. Rather than type 'Win2000!B43" simply click on the 
"Win2000" sheet and then click on cell B43. You should get the answer 68. 
 

2. Fill the formula down from C6 through C8. Looks like a problem, doesn't it?  
 
3. Select cell C6 and take a look at the formula. Notice that cell B43 is now B44. Select cell C7. 

Notice that cell B43 is now B45. What is going on - things are getting worse! Unless we tell 
Excel otherwise, cell references will automatically be adjusted when doing a fill. This is 
called relative addressing, which is fine if the cell you are referencing is always one cell to 
the left, for example, as you move down rows. But if we always want to reference the same 
cell, in this case cell B43, we have to make it an absolute reference. We do this by putting $ 
signs in front of the row and column in the formula. The next step will show us how. 

 
4. Select cell C5. In the formula bar, shown below, highlight the first cell B43, and then press 

the F4 key on your keyboard. This will automatically insert the "$" in front of the row and 
column numbers. Do the same for the other two B43's and then hit the "Enter" key or click 
on the "check mark" to the left of the formula bar.  

 
 

 
5. Fill the formula down again to C6 through C8. It should look better now. 
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Using VLOOKUP to Look Up Values in a Table 
 
1. Select the "Accounting" sheet. Please note that the cost items have been made up, and are not 

actual costs. Select the cells containing the information below (cells A3 to B7): 
 

Supplies Cost per Item 
Folders $          0.25 
Diskettes $          1.00 
Name Folders $          0.05 
Water Bottles $          .75 

 
2. Give this table the name "supplies" by typing "supplies" in the "Name" box which is directly 

below the "Font" box, as shown below:  
 

 
Remember to hit the "Enter" key after you type "supplies". You should then see: 

 
3. Select cell B11. In this cell we want to calculate the cost of each of the supplies for the 

courses given in July and August, which is the cost per item multiplied by the number of 
items used. To calculate the cost of each item, we will look up the item in the table we just 
created. We do this with a VLOOKUP function. There 4 arguments in the VLOOKUP 
function, as follows: 

 
VLOOKUP(arg1,arg2,arg3,arg4) 
 
Where: 
Arg1 the cell you are looking up (A11) 
Arg2 the name of the table that we are looking into (supplies) 
Arg3 the column of the table that contains the value we want (2) 
Arg4 we set this to "0" so that we get an exact match on the lookup 
 
In the "Inventory" sheet, cells C5:C8 contain the number of folders that we used in the 
courses. We are now ready to enter the formula as follows: 
 
 =VLOOKUP(A11,supplies,2,0)*Inventory! C5 
 
To enter the second part of the formula, you would click on the "Inventory" sheet and select 
C5 and hit the Enter key. Try it now.  
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4. Fill the formula down to cells B12 through B14 in the "Accounting" sheet. Format these cells 
(B11:B14) to currency. The amounts should be: 

 
 Jan-Feb 
Folders $ 17.00  
Diskettes $ 68.00  
Name Folders $   3.40  
Water Bottles $ 51.00  

 

Arrays 
 
1. Click on the "Inventory" sheet. In cell D4 put in the label "Remaining Inventory". Format it 

bold italic like the other column headings. Widen column "D" to accommodate the title.  
 
2. In cell D5, put in the calculation to calculate the remaining inventory for "folders" (=B5-C5). 

Fill this formula down for the cells D6 through D8.  
 
3. In cells E5 through E8, let's put in the cost per item. You can get this information by copying 

and pasting the values, but it is probably best to link to the cells in case the "cost per item" 
changes. (Hint: You can copy the cells B4:B7 in worksheet “Accounting”, do a "paste 
special" and then click on the "Paste Link" button). Put the label "Cost Per Item" in cell E4 
(bold italic).  

 
4. In cell A10 type "Inventory Amount". 
 
5. Click on cell B10. In this cell we want to put the amount of money we have tied up in 

inventory. To do this for "Folders" you would multiply D5 (Remaining Inventory) by E5 
(Cost per Item) and write it down. You would then do the same calculation for "Diskettes", 
and so on for each supply. There is an easy way to do this calculation in Excel, using an array 
calculation. Enter the following formula, but DO NOT press Enter.  

 
=SUM(D5:D8*E5:E8) 
 

6. Hold down the keys "SHIFT" and "CTRL", and now press "ENTER". Your will notice the 
"curly" brackets around your formula. Format the answer ($195.60) as currency. 
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Conditional Formatting 
It is sometimes useful to highlight numbers on your worksheet depending on their values. For 
example, we may want to make the inventory remaining appear in red if there are less than 35 
items left. 
 
1. Select cells D5 through D8 inclusive. From the "Format" menu, choose "Conditional 

Formatting". The following window will appear: 

 
 
2. Make this window look like the following: 

 
 
3. Click on the "Format" button. The following menu appears: 
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4. Click on the "down arrow" beside "Color" and choose Red. Click on the "Ok" button. Click 

the "OK" button again. Click on any cell and one of your inventories should appear in red. 

Workbook Management 

Adding a New Sheet to Our Workbook Using a Template 
If you recall from earlier this morning you created a template called "registration". We will now 
insert a new worksheet into our workbook using this template. 
 
1. Suppose we are adding a new course. This new worksheet will go between the "PowerPoint 

Level 1" sheet and the "Accounting". Right click on the "Accounting" sheet. The following 
window appears: 

 

 
 



SEW – Updated  in March 2003 15

2. Click on "Insert". A window will appear and you should see your "registration.xlt" template. 
Click on it and then click on the "OK" button (or you could double-click on it).  

 
3. Rename this worksheet "Windows 2000 Level 1". (Right click on the tab, choose "rename", 

and then type the new name). 
 
You are now ready to start registering people for this new course. 

Copying and Moving Worksheets Between Workbooks 
It is really simple to copy/move a worksheet from one workbook to another. 
 
4. Open the "Consolidate" workbook from the X-drive and select the "Overall" worksheet. We 

want to copy this worksheet to the end of the"janfeb02registration" workbook.  
 
5. From the "Edit" menu, choose "Move or Copy Sheet…". The following window will 

appear: 
 

 
 
Change this window so that it looks like the following: 
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Notice that the checkbox at the bottom of the window needs to be checked to create a copy. 
 

Concatenating Information in Columns 
Sometimes it is useful to concatenate (join) the information from two columns into one column.  
 
1. Select the "Excel Level 1" sheet. Suppose we wanted to join "First Name" and "Last Name" 

into a new column. Let's first create the new column. Select column "D". From the "Insert" 
menu, choose "Columns".  

 
2. In cell D11, type "Full Name". 
 
3. In cell D12, enter the following formula: 

=concatenate(B12," ",C12) 

You insert a space between the quotes in order to separate the first name and last name with a 
space. 

4. Fill the formula down for the other registrants. 
 
5. If you try to delete the names in columns "B" and/or "C" you will have a problem because 

column "D" is dependent on these columns. Try deleting the names in column "B" and see 
what happens in column "D". Recover column "B". Copy the names in column "D" to the 
clipboard. Create a new column after column "D". Select cell "E12". From the "Edit" menu, 
choose "Paste Special". The following window will open: 

 

 
 

Click on "Values" and then click on "Ok". You can now delete the names in columns "B", 
"C" and "D" and the column "E" names will remain intact.  
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Hiding Columns 
You may want to hide a columns for a number of reasons. One reason could be that you don't 
want the information in a column or columns to be printed.  
 
1. Select columns "D", "E", and "F". From the "Format" menu, choose "Column" and then 

choose "Hide". Do a Print Preview to see what is printed. If you wanted to hide columns that 
were not adjacent, simply hold the "Ctrl" key down while you select the columns. 

 
2. To unhide the hidden columns, select columns C through G and then from the "Format" 

menu choose "Column", and "Unhide".  

Protecting Areas of a Worksheet 
1. Select the "Win2000" worksheet. Suppose we wanted to make sure that cells A1 through 

H11 never get changed. Select cells A12 through H41.  
 
2. From the "Format" menu choose "Cells" (Format=>Cells). The following window will 

appear: 

 
 
3. Select the "Protection" tab (circled above). The following window will appear: 
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4. Click on the "Locked" checkbox to remove the check. Click on the "OK" button. 
 
5. Now protect the document by choosing "Protection" from the "Tools" menu, and then 

selecting "Protect Sheet" (Tools=>Protection=>Protect Sheet). The following window will 
appear: 
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6. Enter a password (if you do this back in your office, make sure you remember the password). 
Click on the "OK" button. You will be asked to reconfirm the password. 

 
7. Try it out by trying to change cell A6, for example. Excel should not let you. Try to add 

another person to the course (this should work). 
 

Splitting an Excel Window into Panes 
If you were registering people for a course it would be convenient to have the name of the person 
stay on the left side of the screen as you enter information required to the right of the screen.  
 

  
 
1. Notice the area on the above worksheet in the bottom right corner that is circled. Click your 

mouse on the area just to the right of the "right" arrow and drag it to just after column "C".  
 
2. Notice the area on the above worksheet in the top right corner that is circled. Click your 

mouse on the area just above the "up" arrow and drag it to row 10. Your worksheet should 
now look like the following.  

 



SEW – Updated  in March 2003 20
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Printing Tips 

Repeating Column Headings When Printing Large Worksheets 

You may have a worksheet that contains a lot of rows, and will take several pages to print. It 
may be handy to have the column titles at the top of each of the subsequent pages.  

1. Click on the "PowerPoint Level 1" sheet. From the "File" menu choose "Page Setup". Select 
the "Margins" tab and change the top and bottom margins to 4"  . From the "Page" tab, 
change to "Landscape" orientation. 

 

2. Do a print preview (click the "Print Preview" button) to see what the output will look like 
when printed. Notice page 2.  
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3. Click on the "Close" button at the top of the page. Go back to the "Page Setup" window 
(from the "File" menu). Click the "sheet" tab, and the following window will appear: 

4. Click your mouse in the window to the right of "Rows to repeat at top". Now click on row 
11. 

5. Click on the "Print Preview" button and notice the headings at the top of the second page. 

6. Click on the "Close" button. Click on the "Page Setup" from the "File" menu again. With the 
"Page" tab selected you will see the following window: 



SEW – Updated  in March 2003 23

Notice under "Scaling" the button to fit the worksheet on one page. You will be using this when 
you do the project. 

Headers and Footers  
Just like in word processing, Excel has the capability to create headers and footers.  
 
7. From the "View" menu, choose "Header and Footer…". The following window will appear: 

 
 
8. Click on the "Custom Header…" button. The following window will appear: 

 
9. You can enter information on the left, center and right side of the page. There are also a 

number of buttons available to you for entering information such as the page number and 
the date. Try creating your own custom header and do a print preview to see it. 
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Pivot Tables 
Pivot tables provide an excellent tool for summarizing data. In our example, we will use a pivot 
table to find out what faculties and departments are taking the Win2000 course.  
 
1. Select the “Win2000” worksheet and select cell B13 (or anywhere in the range containing the 

course registrations).  
2. From the Data menu, select “PivotTable and PivotChart Report”. The following window will 

appear: 
 

 
 

2. Click on the “Next >” button, and the following window will appear: 
 

 
 

3. Click on the “Next >” button and the following window will appear: 
 



SEW – Updated  in March 2003 25

 
 

4. Click on the “Layout” button and the following window will appear: 
 

 
 

5. We will pivot around the “Faculty” information, so let’s drag the “Faculty” button to the 
“Page” location. When we are looking at the information for a Faculty or Admin area, we 
would like to see our registration list broken down by staff and faculty. Drag the “Position” 
button to the “Row” location. Drag “Department” to the “Column” location so that we can 
see how many are coming from each department in a faculty or Admin. Finally, drag “Last 
Name” to the “Data” area. The window should now look like the following: 
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6. Click the “OK” button, and then click on the “Finish” button. We should now be looking at 

the pivot table below: 
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7. In Cell B1, click on the “down arrow”, and choose “Science” and click the “OK” button. We 
can now see who is taking this course, from each department in the Faculty of Science. Now 
let’s pivot, by choosing “Admin” in cell B1.  

 
Notice that this pivot table resides in a new sheet in our workbook. You can spend a lot of time 
learning about pivot tables and pivot charts. They can be very useful and very powerful for some 
applications.  

Memorizing and Running Macros 
If you find yourself repeating the same sequence of commands in Excel, you could save time by 
telling Excel to memorize and repeat what you do.  
 
1. Click on the "Inventory" sheet. From the "Tools" menu, select "Macro" and then "Record 

New Macro", as is shown below: 
 
2. The following window will appear: 
 

 
In the "Macro name" box type in Graphit, and then click the "OK" button. You will notice that 
the following small button will appear. Just ignore it for now. 

 
3. Click on the "Chart Wizard" tool.  
 
4. Using the chart wizard, we will create a column chart. When you get to the second step you 

are going to be asked to enter the data range. You can either move the "Step 2 of 4" window 
out of the way, or click on the button located at the end of the "Data range" window.  

 
5. Now select cells A4 to A8, then hold down the "Ctrl" key and select cells D4 to D8.  
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6. Finish the steps to create a graph that looks like the following: 
 

 
 
7. Click the "Stop Rec" button. You have just created a macro called graphit.  
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8. We now want to repeat the procedure. This time we will let Excel do all the work using the 
macro we just created. First click on the graph and then cut it. From the Tools menu, choose 
Macro, then choose Macros again, as shown below: 

 
 
The following window will appear: 
 

9. Click the "Run" button. Your graph should appear. Remove the graph again. 
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10. We can get even fancier using a button to invoke the macro we just created. From the 
View menu choose "Toolbars" and then select "Forms". The following window will 
appear: 

 
 
11. Click on the button that is circled above and drag out an area on your worksheet to represent 

the button. The following window will appear: 

 
 

12. Click on "graphit" and then click on the "OK" button. 
 
13. Type the name "Graphit" for the button. Click on any cell in the worksheet. 
 
14. Click on the button, and your graph should appear.  
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Some Advanced Formatting Tips 
 
In Excel Level 1 you learned how to import non-Excel data into Excel. This exercise will review 
that process but also change the format of some data at the same time.  
 
1. We are going to import the file called "students" from the X-drive. This file contains students 

with student numbers starting with "00" (two leading zeros). One option is to convert the 
numbers to text when importing, which means the leading zeros will remain intact. When 
you start the Text Import Wizard, click on the "Text" button in the "Column data format" 
window (step 3 of 3), as shown below:  

 

 
 
2. Your student numbers will now remain intact. If you want to sort the student numbers you 

will need to convert the id numbers back to actual numbers. You can do this by putting 
the number one (1) in any blank cell, copy it to the clipboard, select all the student 
numbers and do a paste special.  

 
3. Choose the multiply operation. You will have converted the text back to numbers, but again 

the leading zeros are dropped.  
 
4. Another way to get the leading zeros back is to select cells, choose Format->Cells and then 

pick custom. Select 0 and then fill in seven more 0's, as shown below: 
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If you has already imported the student numbers as numbers, doing the formatting as we did in 
this step would be all you would need to do to get the leading zeros to display. 

5. Close all your worksheets.  

This completes the course. You can always learn more about Excel.  

Text to Speech 

One of the new features in Excel 2002 is the ability to have Excel read the contents of selected 
cells to. Open the workbook called “studentfinalmarks” from the X-drive.  

1. Select cells B3 thru C8 inclusive.  

2. From the View menu, select toolbars, and then choose “Text to Speech”. The following 
window will open: 

 

4. Click on the “Speak Cells” button  and the marks for each student will be read to you.  

We have now completed the instructional part of the course. You will now work on a project that 
requires you to use the skills you learned in this handout. In order to get a certificate for the 



SEW – Updated  in March 2003 33

course, you need to work on this project. Two instructors are available to help with any problems 
you encounter.  

 


